View Full Version : Unable to read memory card

20-05-2021, 11:02pm
I am the owner of a Sony A77 which has decided that it is now unable to read memory cards, and suggests to reinsert the card.
Trying this is not working with any cards which are currently being used or any new card.
Has anyone had this experience, or have any ideas to solve this problem, so I can get back to making photos again.

Thanks in advance

21-05-2021, 2:18am
If you do a hunt on google, this is not an uncommon problem for the A77. It may be worth trying a reset back to the default A77 settings. That has worked for a couple of people. Someone else had to return the camera and have the card reader replaced as that was faulty. If the A77 still has a place for a memory stick, have you tried one? That works for some people.

21-05-2021, 10:19pm
Thanks for the reply Farmmax, I think that it may be a job for a camera repairer.
I cannot open the menu as the message to reinstall the memory card comes on instantly.
I have read some of the A77 memory problems on Google, it puts me off Sony a bit.


22-05-2021, 12:57am
I don't think you need to access the menu's to reset the Sony A77 back to the factory settings. There is another way to do a hard reset.

Here are some instructions from a Flickr A77 group in case you want to try them https://www.flickr.com/groups/a77/discuss/72157632965511806/ Have you had a talk to Sony to see what they think the problem may be?

1. Turn off A77.
2. Take out battery. (leave out for 5 minutes)
3. Insert battery again.
4. Turn a77 on
5. Press these 3 buttons Menu+Movie+Playback simultaneously
6. Turn camera off without releasing buttons
7. Turn camera on, Alpha logo should appears, count to 5 and release buttons.

Below is a similar official version provided by Sony for the A77, but back in 2011

We recommend, before doing this procedure, that you turn the camera off and remove the battery for a few seconds.
Turn ON the camera.
Press MENU, Play, MOVIE buttons simultaneously.
While Pressing these buttons, turn OFF the camera.
Release your fingers, and wait over 30 seconds.
Press MENU, Play, MOVIE buttons simultaneously again.
While Pressing these buttons, now turn ON the camera.
Release your fingers.

If your problem is a faulty card reader, none of the above is much use. The camera probably needs to go back to Sony.

22-05-2021, 1:19am
I have had that problem when travelling through the Kimberley but the only way I could get it to work again was by having it serviced. Cost about $250 from memory but that was back in 2016. Fortunately I had other cameras with me so I wasn't that inconvenienced

It was perfectly ok after that and I've now given it, and all my A mount glass, to our daughter so I hope it continues to work ok for a long time to come

23-05-2021, 10:43pm
Thank you Farmmax and John R for your replies.
I tried the suggestions above but alas, it did not help. I will have to take the camera in for repair.


29-05-2021, 8:54pm
The camera is in for repair,
it needs the C/O MAIN PCB WITH FPC replaced. Total cost $466.50
I'm not complaining, it's too good a camera to be out of action.