User Tag List

Thanks useful information Thanks useful information:  0
Results 1 to 4 of 4

Thread: Problem with Tamron Lens SP AF 17-50 XR Di-II VC LD

  1. #1
    Member
    Join Date
    01 Feb 2011
    Location
    Maroubra
    Posts
    164
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problem with Tamron Lens SP AF 17-50 XR Di-II VC LD

    I purchased this lens from DWI on the internet about 15 months ago. This lens has started to give me some problems. After I take a photo I get a message on my camera's screen that "Communications between lens and camera is faulty. Clean contacts on lens." I then need to turn the camera off and on again to reset. The photo is OK but this error message happens abiut 70% of the time. I have cleaned the contacts on the lens but the problem still happens. There are no problems with my other lenses. My camera is a Canon 50D.
    Has anybody had this problem before?
    I presume the lens is out of its 12 months warranty so is there a reputable repairer for Tamron Lens in Sydney?

  2. #2
    Administrator ricktas's Avatar
    Join Date
    24 Jun 2007
    Location
    Hobart
    Posts
    15,643
    Mentioned
    10 Post(s)
    Tagged
    1 Thread(s)
    how did you clean the contacts? a little bit of metho on a cloth works (make sure camera is turned off), or even a pencil eraser, to clean the contacts. it could also be a loose connection, where when you lock the lens onto the body, it has some slight movement, check that as well.

    The tamron reps details are here
    "It is one thing to make a picture of what a person looks like, it is another thing to make a portrait of who they are" - Paul Caponigro

    Constructive Critique of my photographs is always appreciated
    Nikon, etc!

    RICK
    My Photography

  3. #3
    In Training MarkChap's Avatar
    Join Date
    09 Jan 2008
    Location
    Widgee,
    Posts
    2,255
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Not sure about a repairer in Sydney, I do know that Maxwells, the Australian importer, send all Tamrom warranty work to Perth.

    One advantage of buying local would have been the 2 year warranty you would get through Maxwells.

    Have you tried to clean the contacts on the camera, what did you clean the lens contacts with ??
    Smoke Alarms Save Lives, Install One Today
    I shoot Canon
    Cheers, Mark


  4. #4
    Member
    Threadstarter

    Join Date
    01 Feb 2011
    Location
    Maroubra
    Posts
    164
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for the help, I did clean the contacts on both camera and lens with metho. I have just found out that the problem only happens when the auto focus is turned on. When I use manual focus there is no problem. I think I need help from the Tamron rep.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •