User Tag List

Thanks useful information Thanks useful information:  0
Results 1 to 3 of 3

Thread: Minolta 28-100mm no longer working on my a350

  1. #1
    Ausphotography Regular
    Join Date
    15 May 2011
    Location
    Sydney
    Posts
    675
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Minolta 28-100mm no longer working on my a350

    I keep gettin a shutter is locked lens not connected message when I connect up my old trusty 28-100mm.

    All my other lenses are fine just this one and it only just started this week. Anyone got any ideas as I LOVE this lens over the Sony 18-70 kit lens and I dont want to lose it
    Cartel Imagery
    Flickr


    Nikon D7000
    Sony a65
    Canon 5D MKII

  2. #2
    Mark mpb's Avatar
    Join Date
    28 May 2010
    Location
    Northern Rivers
    Posts
    1,936
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I would try cleaning the contacts on the lens first. If you know anyone else with a sony (or even minolta) a mount you could try the lens on another camera.
    Mark


  3. #3
    Ausphotography Regular
    Threadstarter

    Join Date
    15 May 2011
    Location
    Sydney
    Posts
    675
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Did both yesterday actually

    I think it is the lens itself as it will not work on my Dynax 5d that then lens lived on for so long. I might send it off to be looked at as it was my favorite all purpose lens

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •