User Tag List

Thanks useful information Thanks useful information:  2
Results 1 to 6 of 6

Thread: My K-5 - A few questions before I post some snaps...

  1. #1
    Member seqo's Avatar
    Join Date
    02 Nov 2010
    Location
    Darwin
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    My K-5 - A few questions before I post some snaps...

    I received my K-5 and Sigma 50mm 1.4 on Friday and happily spent the entire weekend playing with it. Resultantly, I have a few questions:

    1. I am unable to find the current Firmware Revision/Version listed in the Camera Menu. Did I miss something when I read the manual? - Ok, read the whole sticky re: Firmware and found that you can get to it by powering on + holding menu button. Is this still valid for the K-5 though?
    2. The camera makes a rattling (sliding & 'clack'ing) noise when I turn the camera from side to side. Is this normal?


    Hope someone can answer these questions.
    Last edited by seqo; 21-12-2010 at 3:33pm.

  2. #2
    It's all about the Light!
    Tech Admin
    Kym's Avatar
    Join Date
    15 Jun 2008
    Location
    Modbury, Adelaide
    Posts
    9,641
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    1. Download the firmware from Pentax - the readme in the zip file tells you how to do the upgrade - make sure the battery is 100% when you do it
    http://www.ausphotography.net.au/for...-models-thread

    2. Yes, the sensor shakes - its the dust removal system working - all Pentax goodness
    regards, Kym Gallery Honest & Direct Constructive Critique Appreciated! ©
    Digital & film, Bits of glass covering 10mm to 500mm, and other stuff



  3. #3
    Member
    Threadstarter
    seqo's Avatar
    Join Date
    02 Nov 2010
    Location
    Darwin
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Kym, appreciate it. Was a bit worried something was 'loose', as that is what it sounds like (even my girlfriend commented when she was having a play).

  4. #4
    Member
    Join Date
    03 May 2010
    Location
    Gold Coast
    Posts
    341
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Kym,

    is it the dust removal or the shake reduction? ie moving sensor clunking when its not held by presumably magnets, ie is locked in when taking a photo or SR is switched off. The dust removal tends to be a higher pitch noise?

    either way its all good as all pentax dslrs do it

    cheers,

    Tim
    K7, Pentax DA35Ltd, DA70Ltd, DA18-55WR, DA50-200WR, SMC-K 400f5.6; Sigma 8-16mm; Super TakumarM42 20f4.5, 24f3.5, 28f3.5, 35f3.5, 55f1.8, 135f3.5, SMC 200f4, SMC 85-210f4.5

  5. #5
    It's all about the Light!
    Tech Admin
    Kym's Avatar
    Join Date
    15 Jun 2008
    Location
    Modbury, Adelaide
    Posts
    9,641
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    When you turn on it shakes rattles and rolls, attempting to shake any dust off the sensor.

    When you squeeze the shutter release, it adjusts for movement based on the piezoelectric gyros (solid state), i.e. Shake reduction.
    Note: Pentax will get more shots from a battery charge than a VR/IS canikon as the VR/IS means motors constantly adjusting the lens, whereas Pentax do it only when the shutter actuates.

    Dust Removal: DR II (K-7 onwards) works using and ultrasonic vibration of the low pass filter, there is a sticky strip below the sensor that catches the dust.

  6. #6
    Member xjjohnno's Avatar
    Join Date
    30 Aug 2010
    Location
    Melbourne
    Posts
    55
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    To find the bios version, hold the menu button while turning on the camera.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •