User Tag List

Thanks useful information Thanks useful information:  0
Results 1 to 4 of 4

Thread: Pocket Wizard Problems 580exii sock

  1. #1
    Member
    Join Date
    24 Jan 2010
    Location
    FNQ
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Pocket Wizard Problems 580exii sock

    Does anybody else run canon 580exii 's with flextt5's and miniTT1, having random problems with it? ETTL seems to be not working properly, sometimes.

    I have checked out pocket wizard site and noticed US customers get a free 'sock' to stop the interference. Does anybody here down under have anything like that? i cant seem to find anything.

    Also how do u go about mounting the 580exii and flextt5 to a umbrella bracket or soft box as the flex raises the flash another inch or so?

    cheers

  2. #2
    Ausphotography Site Sponsor/Advertiser DAdeGroot's Avatar
    Join Date
    26 Feb 2009
    Location
    Cedar Creek, Qld, Australia
    Posts
    1,890
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Are you running FCC or CE Pocketwizards. If they're FCC (i.e. ordered from the US), they'll have the issue that requires the use of a "sock", BUT not being a US resident, you'll need to source one from someone over there that is, or pay up for one yourself.

    If they're CE versions, they, theoretically don't need a "sock".
    Dave

    http://www.degrootphotography.com.au/
    Canon EOS 1D MkIV | Canon EOS 5D MkII | Canon EOS 30D | Canon EF 400mm f/5.6L USM | Canon EF 70-200mm f/2.8L IS USM | Canon EF 17-40mm f/4L USM | Canon EF 85mm f/1.2L II USM | Canon EF 35mm f/1.4L USM | Canon TS-E 17mm f/4L & some non-L lenses.

  3. #3
    Member
    Threadstarter

    Join Date
    24 Jan 2010
    Location
    FNQ
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ohh really? ok thanks. They are CE versions. i'm not sure whats happened then.

  4. #4
    Member Cris's Avatar
    Join Date
    02 Feb 2009
    Location
    Noosa
    Posts
    264
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had noticed some issues when I upgraded from a 5d to a mkii, however since the latest firmware upgrade all is good and no issues, plus you get to use the modelling light feature. I may be lucky in that I am using 2 430 exii and one 580.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •