User Tag List

Thanks useful information Thanks useful information:  3
Results 1 to 7 of 7

Thread: A FastStone Issue...

  1. #1
    Arch-Σigmoid Ausphotography Regular ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    21,518
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)

    A FastStone Issue...

    ...that started a couple of days back for NO APPARENT REASON
    Preamble...
    I run Win 10 Home, and I have always had FS work flawlessly until two days ago.
    No update for Win 10 occurred and the problem I now have began after I had been
    using FS for about half an hour. Originally I had V 5.1, but then I updated to the latest,
    thinking it would solve the problem. It did not.

    Here's what happens...
    FS appears to open and work properly, whether from its own icon or by double-click on an
    associated file. But then, when you press M to Move a file to another folder...
    1. The file remains visible on the screen until you scroll the mouse wheel to go to the next file.
    2. After that, pressing the M key again, or the Escape key, or closing the window using the X button
    ALL DON'T WORK.
    The last image remains displayed, and I can only shut down FS using End Task from Task Manager.
    Also when I close the App that way, the Process does not always close, and then...
    3. You can't re-open FS by clicking its icon or on an associated file until I close the process as well in
    Task Manager.

    Ta.
    Am (a bit perplexed about it).
    CC, Image editing OK.

  2. #2
    Member
    Join Date
    29 Jul 2015
    Location
    Greensborough
    Posts
    1,655
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I only use faststone. I don't use the M button, if I want to move something I drag it to it's new location. But something is different. If I open a file using "right click" and then got edit "right click" and go to crop, it gives me the crop over the original file at 95% of the screen. so I can still see the original file underneath. But it all closes ok.
    I have been taking photos for 50 years. I am now trying to get into Photography


  3. #3
    A royal pain in the bum! arthurking83's Avatar
    Join Date
    04 Jun 2006
    Location
    the worst house, in the best street
    Posts
    8,718
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    I don't use those shortcut keyboard keys you mention Am, and in general I don't use FSV to move images around anyhow

    ** not because it's not good at it, but more so that I prefer to use ViewNX2, because it can sometimes go goofy on the next run if images have been moved by another program **

    But to help solve/track down your issue you could:

    Uninstall completely and clean up registry post uninstall, and re-install .. or!
    Try the fully inclusive mobile version of FSV.

    The all inclusive or mobile version of FSV will sit in a folder wherever you have extracted it too, and run without any previous reference to the installed version.
    ie. you could run the mobile version of FSV off an external storage system of some description on a computer(Win) and not have to install it on that PC.

    Personally, I'd try the mobile version as my first step(in the problem solving routine) to see if it does the same goofy sounding problem, and if it doesn't, then I'd look at uninstalling, cleaning registry and then re-installing latest version again.

    Note that of the one and only issue I've ever had with FSV where it hung, was due to a corrupted file it tried to display only in the thumbnail list. So technically it wasn't FSVs problem in any way, but it somehow got corrupted somewhere in it's installed files, so I did the uninstall/clean reg/reinstall thingy and it worked fine again.
    Nikon D800E, D300, D70s
    {Nikon} -> 50/1.2 : 500/8(CPU'd) : 105/2.8VR Micro : 180/2.8ais : 105mm f/1.8ais : 24mm/2ais
    {Sigma}; ->10-20/4-5.6 : 50/1.4 : 12-24/4.5-5.6II : 150-600mm|S
    {Tamron}; -> 17-50/2.8 : 28-75/2.8 : 70-200/2.8 : 300/2.8 SP MF : 24-70/2.8VC

    {Yongnuo}; -> YN35/2N : YN50/1.8N


  4. #4
    Arch-Σigmoid Ausphotography Regular
    Threadstarter
    ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    21,518
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Ta AK. I mucked around a bit more and I think you might be on the right track.
    This seems to have been restricted to a group of folders on an external drive.
    FSV certainly threw wobblies there. I copied the files out of those folders onto
    another drive and the same thing happened. On checking other drives/folders,
    FSV acted well as usual.

    Ta.

    BTW, I found I was a couple of versions behind and updated part way through
    this episode. The new version made no difference. Anyway, those files are gone
    now, and all looks good.

    - - - Updated - - -

    ---And another thing. I noticed that if you double click on a non-associated file first, FSV chucks a
    "half-wobbly". It forgets that you had a "Move-to" folder and forces you to re-define it. After that
    it seems to be OK.

  5. #5
    A royal pain in the bum! arthurking83's Avatar
    Join Date
    04 Jun 2006
    Location
    the worst house, in the best street
    Posts
    8,718
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    I've had my fair share of corrupted images over the years:

    ViewNX2 just shuts down with no reason why, and the next time you open it up(it always opens at the last directory you viewed when you closed it down!) it just does the same thing ..
    of course you don't know what's happening as there's no error .. just the shutdown.
    FSV, on the other hand, will try to open the corrupted file, and the most likely result is that it doesn't respond(as you described) and then doesn't close down properly(as you also described).

    Both have their advantages, but overall(of the two methods of dealing with the issue) I do prefer the ViewNX2 version of how to deal with it.
    I reckon a better way to deal with it tho is a proper error message describign what's going on, so that you're not chasing your tail with fixes that don't do anything.

  6. #6
    New Member Poppyrob's Avatar
    Join Date
    16 Nov 2009
    Location
    Northern NSW
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I would like to update my version of FastStone for no real reason other than to have the latest issue. My dear old Dad used to say "if it isn't broken, don't fix it", but I might give it a shot anyway ....

    I have a question ... Over the years I have tagged quite a few files using their basic tagging facility, but if I update to a later version, I should imagine the tags will disappear. After looking through the FastStone folder, I can see no obvious file to copy and drag across into a later version. Or do I have this all wrong, and the update will simply add and adjust files to the existing software rather than install a complete new program?

    Anyone?

    Thanks.

  7. #7
    Arch-Σigmoid Ausphotography Regular
    Threadstarter
    ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    21,518
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    A good Q, alright.

    First, I reckon it wouldn't wreck the tagging system done by the previous version,
    but I've got no proof.

    I found two versions on my computer: V5.1 and V6.2. The first one has a file named
    FSSettings.db, which has lots of references to "tag". None of the other ".db" files do.
    However, the later version does not contain that file, and the few I checked had no
    such refs. Open the files using Notepad and do a search for "tag".

    If you're concerned, try installing both versions. They have different folder names, anyway.
    They're both located under Program Files(x86). One of mine is in folder FSViewer51, and the
    other is in folder Faststone Image Viewer. Make sure you don't overwrite the old folder with
    the new installation.

    Once you have the two installed, copy some files into a test folder, tag them with the old
    version of FS, then open them and check the tags with the new version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •