User Tag List

Thanks useful information Thanks useful information:  0
Results 1 to 4 of 4

Thread: K-r will not turn on

  1. #1
    New Member
    Join Date
    23 Nov 2015
    Location
    Highton
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    K-r will not turn on

    Hi,

    Wondering if anyone can be of assistance??

    My K-r will not power on. Was using it a while ago and, as the battery in it went flat mid shoot I changed to a fresh battery (D-LI109). When I went to turn it back on, NOTHING!!!! I have tried it with different batteries (all fully charged), but to no avail.

    Camera has had 73,001 shutter actuations (as at the last shot taken).

    My budget does not currently extend to taking the camera in to get looked at by a tech if it's going to cost too much, but may have to bite the bullet (any idea what sort of cost this may attract)?

    I am currently using my old *istDS but really need something with a higher fps rate before next footy season (finding the 2.8fps of the *ist a bit of a pain).

    Any thoughts/sugestions would be greatly appreciated as I truely love the K-r and it has served me well over the last few years (maybe this is the nudge I need to upgrade - once I save up a few more $'s).

  2. #2
    Carpe Diem... Gazza's Avatar
    Join Date
    24 Mar 2013
    Location
    无聊 Birdwoodton
    Posts
    6,313
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    I had a similar problem with my Canon 7D some time back, it ended up being the switch/sensor on the battery door/cover (Think fridge door switch for the light )

  3. #3
    Account Closed tduell's Avatar
    Join Date
    10 Nov 2013
    Location
    Melbourne
    Posts
    822
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by peterwa1969 View Post
    My K-r will not power on. Was using it a while ago and, as the battery in it went flat mid shoot I changed to a fresh battery (D-LI109). When I went to turn it back on, NOTHING!!!! I have tried it with different batteries (all fully charged), but to no avail.
    Any success?
    I would guess that you have tried this, but just in case...I would try cleaning the battery contacts in the camera, using a dry cloth or somesuch. A long shot?

    Cheers,
    Terry

  4. #4
    New Member
    Threadstarter

    Join Date
    23 Nov 2015
    Location
    Highton
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy

    Hi Terry,

    Have cleaned the battery contacts - still no joy!

    Have now noticed a "rattle" inside the body. I'm thinking something has come loose inside and maybe caused a short??

    I think it's looking more like a case of replace rather than repair at this stage.
    Last edited by peterwa1969; 03-12-2015 at 11:50pm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •