User Tag List

Thanks useful information Thanks useful information:  24
Page 1 of 2 12 LastLast
Results 1 to 20 of 39

Thread: Anyone having problems with Error 2 messages on the 7D Mk 11.

  1. #1
    Loves The Wildlife. Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)

    Anyone having problems with Error 2 messages on the 7D Mk 11.

    Used my SanDisk Extreme 16GB 120MB/s CF Card once when I took it to Australia Zoo a few weeks ago it went in the camera and I got it out the next day ok.
    Worried about the 36GB SanDisk SD card falling apart like my other two so yesterday I put the CF back in the Camera to format it and I could not shut the door so I left it, had another go later same thing.
    This morning I tried again the door shut ok this time but I get a Error 2 message telling me to format the card and the camera wont let me do that.

    I ring Canon did I get much Help NO after taking my phone Number and email address was told by that person he would email me right back with info on how to send it back to Canon.
    Six hours later I was still waiting.

    Rang Photo Continental where I bought the camera, spoke to a lovely young man who gave me so much help
    Tried out different things and different CF Cards with no success then the door would not close again so he told me to get a torch and magnifying glass and have a look at the pins.
    I told him that was the first thing I did yesterday and none looked bent to me, and they still dont look bent, I am taking it back there next week they are going to look as my eyesight is not 100% anymore.
    And if needing repairs they will send it to Canon for me. I have found here and on line where the older 7D was having the same problem with CF cards. Not having much luck with new cameras in the past 12 months.
    Last edited by Mary Anne; 20-02-2015 at 10:56am.

    I shoot with Canon And Olympus Cameras



  2. #2
    Arch-Σigmoid Ausphotography Regular ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    16,793
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    Sounds like Err 2 stands for 100% BAD!

    Don't think me a pot stirrer, but did you have it the right way around? It can be done, just ask me

    Else, did you: try another card?; try offending card in another carrier (eg, a card reader)?

    Knowing you, the answers would all be "Yes".
    CC, Image editing OK.

  3. #3
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Yes and Yes .. Tried lots of other things too.

  4. #4
    Fishy bricat's Avatar
    Join Date
    06 Apr 2010
    Location
    Melbourne
    Posts
    777
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sometimes we need to leave things for an hour or two, then go back and bang it goes straight in and you wonder what the trouble was? Can you try the cards in another camera? It would appear strange that it suddenly does not fit. Just re-read your post and it looks like you have tried again. I have not had any problems like that with my 7D in many years of use. I am pretty sure it will be a minor glitch in owning any of these high tech gadgets these days and it will long be forgotten once you have it working 100% again cheers Brian.
    Cheers Brian.

    Canon 7D Kit lenses EFS 18-55 IS EFS 55-250 IS EF28-90 Canon EF 2xll Extender Sigma DG150-500 OS Speedlight 420EX. 580EX

  5. #5
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Brian Thank You. Reading through all of this link http://photography-on-the.net/forum/...d.php?t=921353 it seems many people have experienced this problem with the first 7D camera.
    The fault was fixed when the CF Pin FPC assembly was replaced though it seems strange that sometimes I can get the card in the slot and shut the door other times I cant.

    I have tried the SanDisk Extreme 111 CF 4 GB 30MB's from my 40D also tried the SanDisk Extreme CF 16GB 60MB's cards that I use with my 5D MK11 and none of those cards will go into the 7D MK11 camera.
    Yet I have no problems putting that newer SanDisk Extreme 16GB CF 120MB's in the other two cameras taking photos and looking at them on the computer putting them back into the different cameras and formatting them.
    No Problems using the SanDisk 36GB SD card in it as I have been using that one all the time. And the 7D MK11 is going to Canon.

  6. #6
    Fishy bricat's Avatar
    Join Date
    06 Apr 2010
    Location
    Melbourne
    Posts
    777
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes let Canon find and fix this problem. I did a search on the net after reading your link and found this link
    http://www.canonrumors.com/forum/index.php?topic=8194.0 This is said to be error codes for most EOS cameras. Might be helpful to somebody.
    I use mainly 32 gb cards so don't have to change them too frequently unless we go on holidays. let us know the result when you get your camera back. cheers Brian

  7. #7
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Thanks for that link Brian there are more errors there now than years ago, the only one I have had before is the error 99 on the 40D.
    Easy to fix by cleaning the battery terminals with an eraser, only had to do that once so no damage to any parts of the camera
    If it stops raining by Monday afternoon I will take it back to Photo Continental they will send it back to Canon at no cost to me.
    And Thanks for replying again Brian and Yes I will put the results on here, it could be a while though

  8. #8
    Ausphotography Regular crafty1tutu's Avatar
    Join Date
    15 Jan 2010
    Location
    Seven Hills
    Posts
    1,826
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am sorry to hear of your problems Mary Anne. I am going to buy the new 7D MK II but was going to wait until around July before our trip in August, but I may have to buy one sooner and make sure I have no problems. My 7D died while we were in South Africa last August after replacing the CF card due to one being full. Luckily I had taken my 5D MK III with me so I didn't have to change lens from the 100-400 to the 24-105, so in the end I just used the 5D. After sending it to Canon for a quote, I decided not to go ahead as the quote was nearly $500, Canon sent the camera back to me. Guess what, it has been working since it arrived back, so not sure what happened there. I was told the whole top cover cabinet of the camera needed to be replaced, but that wasn't done.

  9. #9
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Thank You Ann I am not doing well at all this past year with either of my new cameras, then there was the SD cards falling apart still waiting for them to be replaced.
    I remember reading about your 7D and the problems you had with it, such a shame when you were on holidays glad you had the 5D3 though.
    Seems that CF card problem is well known. I can understand you not wanting to pay that much for the repair sometimes better to buy a newer model.
    Strange that it works well for you now, it is so good to read that and whatever you decide to do I hope you wont have any problems with the new camera.

  10. #10
    The Commander mikew09's Avatar
    Join Date
    27 May 2009
    Location
    Lowood, Queenland
    Posts
    4,737
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm, not good to hear you are having issues with your new 7D2 Mary Anne. I was considering getting one as a second body to put my 70-200 on for event shooting but I am a little unsure now as I have heard a couple of times now about the card issues. I rely liked the reviews of the 7D2 also. Hopefully they will fix the problem going forward and you will be happy again.
    Please be honest with your Critique of my images. I may not always agree, but I will not be offended - CC assists my learning and is always appreciate

    https://mikeathome.smugmug.com/

    Canon 5D3 - Gripped, EF 70-200 L IS 2.8 MkII, , 24-105 L 4 IS MkI, 580 EX II Speedlite, 2x 430 Ex II Speedlite


  11. #11
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Mick not long come back from taking the camera to Photo Continental where I bought it one of the Salesman managed to get the CF card in and said to me there is nothing wrong with it
    Twice he took the CF out and put it back in again and told me to put it in and I did, he even said to me Mam with no disrespect did you put the card in back the front
    You are joking I said there is only one way the card goes in, I never knew it would go in back the front anyway how would I know if I have never tried it. I just tried it and it wont go in at all
    Though what he didn't do was click that shutter button.. Imagine my disappointed when I tried the camera a half hour ago to find it will not take a photo.

    Message on the screen * Err 02 Card 1 cannot be accessed Reinsert/change card 1 or format card 1 in camera* I cannot format card 1 it wont let me. So back we go again tomorrow.
    Last edited by Mary Anne; 23-02-2015 at 6:26pm. Reason: Added More

  12. #12
    Arch-Σigmoid Ausphotography Regular ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    16,793
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    Can't you return it under the condition that the product does not function properly?
    Hiittim with it: He did not test the shutter. - Very wanting!!! - Like a true salesman (only).

  13. #13
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    No because I have had it since Nov 3..
    He was an old fellow Am I reckon a couple of years younger than me. My fault really as I should have done it myself while I was there.
    Though when an experienced Salesperson tells you it working then you assume he is right.. Never again.

  14. #14
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Got the same Salesperson today and after trying three of my CF cards in my 7D Mk11 and finding they wont work and still getting the Err 2 message tried those same CF cards in their 5D MK111
    Of course those three cards worked in their camera so he admitted that yes there is something wrong with the camera so back to Canon it goes.
    He checked the pins in the camera and told me they looked straight though he noticed those three cards of mine are marked underneath in the centre, at least those cards work ok for now.

  15. #15
    Ausphotography Regular crafty1tutu's Avatar
    Join Date
    15 Jan 2010
    Location
    Seven Hills
    Posts
    1,826
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    How did you go Mary Anne??? I relented and bought one the other day second hand would you believe for $1,750 - local pickup. I asked why he was selling and he said he wanted to upgrade to a full frame.

  16. #16
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Hello Ann. I am on holiday at Yamba at present and as from last Saturday 7th March had not heard anything.
    Going home on Thursday so I will give Photo Continental a ring and see if its back yet from Canon.
    That sounds like a good buy for a camera up to four months old.

  17. #17
    Member Unbound's Avatar
    Join Date
    20 Mar 2013
    Location
    Wollongong
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The suspense is killing me. How did things turn out, Mary Anne?

  18. #18
    The Commander mikew09's Avatar
    Join Date
    27 May 2009
    Location
    Lowood, Queenland
    Posts
    4,737
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Me too Mary Anne, I have been following this post as I am considering a 7d2 for a second body so please, please give us an update. Quote "The suspense is killing me" Unquote :-)

  19. #19
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Will get back to you both tonight I tried a few times in the past two hours to get on here, and now that I can its time to go and think about cooking dinner

  20. #20
    Loves The Wildlife.
    Threadstarter
    Mary Anne's Avatar
    Join Date
    19 Dec 2009
    Location
    Brisbane Southside.
    Posts
    36,070
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    I rang Photo Continental last Friday to be told by the Salesman Declan they had not heard anything, Declan said he would get on to Canon and ring me back which he did within 15 minutes.
    He told me they had just sent him an email and he will forward it on to me if I would give him my address so I did.

    I read it while Declan waited on the phone as Canon said this repair was not covered under warranty as the pins have been damaged by some kind of external force and they quoted $263.30 not including Freight to put a $33.18 part in it..

    Declan told me to ring Canon and tell them exactly what happened and about the ERR message so I rang them.
    Turns out the person at Canon who answered the phone was the one that sent the email..
    He told me to send him a email writing exactly what I told him, I also mentioned I have never had any problems like this with my 20D, 40D, or 5D Mk11.

    Still waiting for an answer a week later so I will ring Photo Continental on Monday and if they have not heard anything else I will ring Canon and tell them to send the Camera back and I will pay the Freight..

    I don't care if I cannot use the CF card slot as I have been using the same SD Card since I have had it except for that one time., and have not had any problems.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •