User Tag List

Thanks useful information Thanks useful information:  0
Results 1 to 3 of 3

Thread: Flash repair- Is it worth it ?

  1. #1
    New Member
    Join Date
    19 Jan 2010
    Location
    Melbourne
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Flash repair- Is it worth it ?

    I have a Pentax AF-540 fgz which has suddenly stopped working. I bought it second hand and worked fine and was very happy with its performance. Now, when I turn it on it goes through the start-up OK (i.e. makes charging sound, the back panel lights up, zooms and appears to be fine). However, it does not flash . Also, does not flash when the "test" light is pressed.

    I am wondering if it is worth taking it to repairs or shall I cut my losses and get a new one? Has anyone else had any similar problems? Any recommendations for repairers in Melbourne?

  2. #2
    Ausphotography Regular bitsnpieces's Avatar
    Join Date
    01 May 2014
    Location
    St Albans
    Posts
    1,058
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Only just saw this post now, and not sure if you've already made a decision or not though. Sorry

    But if not, it probably just needs the bulb/lamp changed (I'm guessing it's burnt out), but if it's not that, then it could be a circuit problem.

    I would think repairing is cheaper than purchasing a new one though, and there's nothing wrong with the second hand flash, as you said, works great - the only problem was time and that's normal.

    So I would say, if it can be fixed, get it fixed, if not, then you can get a new one (or another second hand which isn't as old as this one maybe? Will hopefully last longer?)

    As for repairers, I don't know any, sorry.

  3. #3
    New Member
    Threadstarter

    Join Date
    19 Jan 2010
    Location
    Melbourne
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your advice David,
    Only today I drooped it off tat CR Kennedy for an appraisal which will cost $27. They also suggested it was either the bulb or the circuit board (in particular the capacitors). It may need to be sent to Japan for repair but they will quote before they repair. I will wait to see. In the meantime I am scouting for replacements just in case.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •