User Tag List

Thanks useful information Thanks useful information:  2
Results 1 to 13 of 13

Thread: 5d m3 shutter problem!

  1. #1
    Member
    Join Date
    12 Feb 2012
    Location
    Sydney
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    5d m3 shutter problem!

    Hi guys,

    My 5dm3 has some sort of shutter problem. When I on the camera, it will release shutter non stop without me pressing any button. I have tried changing battery and SD card and lens but to no avail. Need help please..thanks

  2. #2
    Arch-Σigmoid Ausphotography Regular ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    16,827
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    A Q: IS that a problem mentioned in the "Troubleshooting" guide in the manual?
    Am.
    CC, Image editing OK.

  3. #3
    Member
    Threadstarter

    Join Date
    12 Feb 2012
    Location
    Sydney
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No. And no error code displayed. It just keeps taking pictures without me pressing any button

  4. #4
    Arch-Σigmoid Ausphotography Regular ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    16,827
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    Yep. Had a look in the manual on-line. Mystery! I suspect it's a return to Canon.
    Maybe someone can shed some other light.
    Am.
    PS. (DRAT! And the manual took a while to load, too!) I forgot to check whether you can do a factory reset somehow.
    Last edited by ameerat42; 12-04-2013 at 8:18pm.

  5. #5
    Member
    Threadstarter

    Join Date
    12 Feb 2012
    Location
    Sydney
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Am. Still not functioning properly. I suspect a circuit problem within it. Its only 13 months old!! Do you know where is the best place to repair it? It is Aussie stock but I wonder if they are gonna repair it FOC as the warranty is only 12 months

  6. #6
    Administrator ricktas's Avatar
    Join Date
    24 Jun 2007
    Location
    Hobart
    Posts
    15,647
    Mentioned
    10 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by aalex View Post
    Thanks Am. Still not functioning properly. I suspect a circuit problem within it. Its only 13 months old!! Do you know where is the best place to repair it? It is Aussie stock but I wonder if they are gonna repair it FOC as the warranty is only 12 months
    Take it direct to the Canon service centre. along with receipts etc. Good luck
    "It is one thing to make a picture of what a person looks like, it is another thing to make a portrait of who they are" - Paul Caponigro

    Constructive Critique of my photographs is always appreciated
    Nikon, etc!

    RICK
    My Photography

  7. #7
    Member
    Join Date
    12 Jul 2012
    Location
    Rockyview
    Posts
    2,087
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Do you have a grip fitted to it? Might be worth taking it off if you do. In any case, I'd be sending it to Canon as suggested above. Do update this thread when you get it resolved. As a 5DMkIII owner myself, I'd like to know the outcome. Good luck with it.

  8. #8
    Fishy bricat's Avatar
    Join Date
    06 Apr 2010
    Location
    Melbourne
    Posts
    777
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Have you updated the camera? Just a thought.
    Cheers Brian.

    Canon 7D Kit lenses EFS 18-55 IS EFS 55-250 IS EF28-90 Canon EF 2xll Extender Sigma DG150-500 OS Speedlight 420EX. 580EX

  9. #9
    Member
    Join Date
    26 Aug 2010
    Location
    Brisbane
    Posts
    252
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by aalex View Post
    Thanks Am. Still not functioning properly. I suspect a circuit problem within it. Its only 13 months old!! Do you know where is the best place to repair it? It is Aussie stock but I wonder if they are gonna repair it FOC as the warranty is only 12 months
    You shouldn't have a problem getting Canon to repair it without any cost to you. Current Australian Consumer Law (see the ACCC) is that there is an expectation that a product should perform as it advertised to for a reasonable lifetime (or words to that effect), and that the manufacturer is obligated to repair it regardless of the warranty period (hence making extended warranties essentially a waste of money).

    http://transition.accc.gov.au/conten...0%20Refund.pdf

    A $3000+ body should be / is designed to last longer than 13 months. I have had a number of products (microwave, espresso machine, etc) repaired outside of the warranty period at no cost without too much problem. I also had Canon repair a lens that had a problem for the second time (the first time I wasn't aware of my rights and simply paid for the repair), the second time I was aware, and even though I had not proof of purchase or any other supporting documentation, Canon repaired it for free as a "sign of good faith".

    Mention the ACCC,make sure Canon are aware that you know your rights as a consumer, and you will get it repaired at no cost to you. The only out they have is if it shows signs of abuse, or it has suffered "accidental damage", ie you have done something to damage it.
    Mark

    Canon 70D w/Grip l Canon 60D w/Grip l EF 100-400 f4.5-5.6L IS USM l EF 70-200 f4L IS USM l EF-S 15-85 f3.5-5.6 IS USM l EF 100 f2.8 USM Macro l EF-S 18-55 f3.5-5.6 IS STM l EF 50 f1.8 II l Canon EF-S 10-22 f3.5-4.5 USM l 430 EX II Flash l Rode Stereo VideoMic l Manfrotto 055XPROB + 498RC2 Tripod l Benro MP-96 M8 Monopod l Lowepro Vertex 200 AW Backpack l Lowepro Pro Runner 300 AW Backpack l PS CS5 Extended l Lightroom 4.3

  10. #10
    Member
    Threadstarter

    Join Date
    12 Feb 2012
    Location
    Sydney
    Posts
    41
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi guys,

    Thanks for the suggestions and feedback. I have just received back my camera from canon service. Its button 2 , shutter actuation problem. They have replaced the defect pcb interface part. Cheers!

  11. #11
    Arch-Σigmoid Ausphotography Regular ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    16,827
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    Good to hear. Happy shooting.

  12. #12
    Member
    Join Date
    23 Jun 2008
    Location
    Adelaide
    Posts
    80
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by aalex View Post
    Hi guys,

    Thanks for the suggestions and feedback. I have just received back my camera from canon service. Its button 2 , shutter actuation problem. They have replaced the defect pcb interface part. Cheers!
    So are you suggesting that it was a "known problem" ?
    Canon 6D
    Canon 40D
    16-35 L 2.8 11 USM
    24-105 L IS USM
    70-200 2.8 L IS USM 11

  13. #13
    Member
    Join Date
    12 Jul 2012
    Location
    Rockyview
    Posts
    2,087
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Replacing the Printed Circuit Board interface part doesn't really tell you, or us, much. Never mind, I'm sure if it is a common problem, we'll all hear about it, just not from Canon Aus.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •