User Tag List

Thanks useful information Thanks useful information:  6
Results 1 to 13 of 13

Thread: possible 24-105 ribbon issue

  1. #1
    Member
    Join Date
    05 Oct 2008
    Location
    brisbane
    Posts
    433
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    possible 24-105 ribbon issue

    hi kids, it seems my 24-105 l is old enough to have the well documented ribbon issues, i am wondering if anyone has had this issue and what, how and indeed how much the solution was, many thanks , ross
    I've done so many things I'm not proud of...and the things I am proud of are disgusting. ~Moe, The Simpsons

    http://Grae-and-co-images.com/

    canon 5dmk 2, some lenses, a couple of sticks to hold them up, a thing that make sun at night, and a sense of adventure

  2. #2
    Who me?
    Join Date
    02 Sep 2007
    Location
    Tweed Heads
    Posts
    2,749
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi Rossco, I know William had this problem and had it repaired in Brisbane (or surrounds) at a reasonable price. If he misses this thread maybe PM him for details. Good luck
    Cheers David.

    Canon 40D/EF-S 17-85 mm IS/Kenko Extenson Tubes/Canon EF 50mm F/1.8 II (nifty fifty)
    Sigma 10-20mm 4-5.6 /Sigma 70-200/ Sigma 1.4 teleconverter/ some Conkin filters | Adobe Photoshop CS6



  3. #3
    Member
    Threadstarter

    Join Date
    05 Oct 2008
    Location
    brisbane
    Posts
    433
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanks mate

  4. #4
    Member
    Join Date
    26 Aug 2010
    Location
    Brisbane
    Posts
    252
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    http://www.ausphotography.net.au/for...-105-f4-L-Died

    I had the same problem with a 17-85, and had it repaired by Canon at no charge (see my posts on the above thread).
    Mark

    Canon 70D w/Grip l Canon 60D w/Grip l EF 100-400 f4.5-5.6L IS USM l EF 70-200 f4L IS USM l EF-S 15-85 f3.5-5.6 IS USM l EF 100 f2.8 USM Macro l EF-S 18-55 f3.5-5.6 IS STM l EF 50 f1.8 II l Canon EF-S 10-22 f3.5-4.5 USM l 430 EX II Flash l Rode Stereo VideoMic l Manfrotto 055XPROB + 498RC2 Tripod l Benro MP-96 M8 Monopod l Lowepro Vertex 200 AW Backpack l Lowepro Pro Runner 300 AW Backpack l PS CS5 Extended l Lightroom 4.3

  5. #5
    Member
    Join Date
    10 Jul 2010
    Location
    Gold Coast
    Posts
    6,346
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by dbax View Post
    Hi Rossco, I know William had this problem and had it repaired in Brisbane (or surrounds) at a reasonable price. If he misses this thread maybe PM him for details. Good luck

    All sorted,David Ross PM'ed me and probably by now it's all fixed , Cost him $320 , BTW He told me Canon still have'nt been aware of a problem with the 24-105L Thats funny cause I reckon where up to about 7 members that have had a problem, All the same Mind you Camera Tech (one man operation) Guarantees his repair not to happen again
    Canon : 30D, and sometimes the 5D mkIII , Sigma 10-20, 50mm 1.8, Canon 24-105 f4 L , On loan Sigma 120-400 DG and Canon 17 - 40 f4 L , Cokin Filters




  6. #6
    Member
    Join Date
    23 Jun 2008
    Location
    Adelaide
    Posts
    80
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by William View Post
    All sorted,David Ross PM'ed me and probably by now it's all fixed , Cost him $320 , BTW He told me Canon still have'nt been aware of a problem with the 24-105L Thats funny cause I reckon where up to about 7 members that have had a problem, All the same Mind you Camera Tech (one man operation) Guarantees his repair not to happen again
    Hmmm....sounds just like certain car manufacturers that continually deny knowledge of a fault yet half of our car club had their vehicles in for just that. That's modern business I guess.
    Canon 6D
    Canon 40D
    16-35 L 2.8 11 USM
    24-105 L IS USM
    70-200 2.8 L IS USM 11

  7. #7
    Account Closed
    Join Date
    09 Nov 2009
    Location
    One Mile Beach NSW
    Posts
    181
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I just had mine repaired in North Sydney by WorksPerfect ($390 - dropped it off on Thursday arvo and picked it up 24 hours later). The man said that he had prepared the new ribbon cable with some coating to protect it better against the chafing which - given the construction of the lens - seems to be unavoidable.

    May be I should have pestered Canon as this seems to be a fairly common fault developing in lenses that are used a little more often than by the avarage amateur (I took 30.000 plus shots with this lens).

  8. #8
    Member
    Join Date
    10 Jul 2010
    Location
    Gold Coast
    Posts
    6,346
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    $330 in Brisbane ( 2 hour fix time), Had mine repaired 18 months ago , No probs yet, The tech did say it should'nt happen again after his fix of the Aperture mechanism and ribbon , Sort of hard to chuck away an "L" series lens
    Last edited by William; 26-11-2012 at 6:38pm.

  9. #9
    can't remember Tannin's Avatar
    Join Date
    16 Apr 2007
    Location
    Ballarat
    Posts
    2,894
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Bloody Javascript ate my post! Trying again.

    I had mine done by William's bloke. (Thanks William.) Fast service, no problems.

    My understanding of the issue is as follows:

    1: Canon are aware of the issue which is why new-build 24-105s (since about two years ago, give or take) are no longer prone to it, or at least less prone. They changed the design of a part. I forget the details.

    2: This qualifies under Australian consumer protection law as a "major fault". Any lens purchased after the new laws came into effect (1st Jan 2011) will be covered by the new law, which requires the vendor to make good the damage, replace the item, or else refund your money in full. (In broad, you have control over which of these options they take, but DYOR for the details, which have escaped my memory.) The expiration of a manufacturer-set time limit (such as "12 months") is of no account here; you are entitled to a remedy for a "reasonable" time, which is generally longer than 12 months, particularly for something like an L Series lens. See: http://www.accc.gov.au/content/index...itemId/1023610 In other words, if your lens was purchased in 2010 or earlier, see your local lens repairer. If it was purchased in 2010 or later, the vendor is obliged to fix it free of charge or replace the lens.

    3: If you bought it overseas or by Hong Kong mail order, you are screwed. Australian consumer protection law does not apply to you. Pay for the repair out of the GST you saved when you bought on-line and be thankful that the fault can be repaired and the fixed lens will use the new part and will be better than new.
    Tony

    People say nothing is impossible, but I do nothing every day.

  10. #10
    Arch-Σigmoid Ausphotography Regular ameerat42's Avatar
    Join Date
    18 Sep 2009
    Location
    Nthn Sydney
    Posts
    16,790
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    Sounds like a good wicket!
    A(blah!)m.
    CC, Image editing OK.

  11. #11
    Member
    Join Date
    13 Aug 2009
    Location
    cranbourne
    Posts
    110
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I also have a problem with my 24 - 105, but wouldnt have a clue if its the ribbon problem, every time i get an error message, i just turn camera off,release the lens,twist halfway off, then lock it back on, problem solved for a while, i have been doing this for nearly 3 years now.

  12. #12
    Member
    Join Date
    22 Sep 2011
    Location
    Brisbane
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I now know what this ribbon looks like .... I fell over as as I sat up most of my lens (the part that snapped off the front of the camera) rolled past me.

  13. #13
    Member
    Join Date
    06 Oct 2009
    Location
    Clayfield QLD
    Posts
    278
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I got mine fixed where William got his fixed, no problems since ( but then have hardly used it either)
    I have this silly idea, that I should actually go and take photos with all this photography gear I have already accumulated, before I collect any more!

    See some of my photos here.
    https://www.facebook.com/pages/David...5888662?ref=hl
    And my very randomly updated blog.
    http://davidarnold.wordpress.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •