User Tag List

Thanks useful information Thanks useful information:  0
Results 1 to 3 of 3

Thread: Canon 50D

  1. #1
    Ausphotography Regular crafty1tutu's Avatar
    Join Date
    15 Jan 2010
    Location
    Seven Hills
    Posts
    1,826
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Canon 50D

    I am wondering if anyone can help me. I have a Canon 50D and have never had any trouble with it. Just recently (the day before we left South Africa after a four week holiday) it decided to stop taking photos. I am so thankful that it was at the end of the holiday and not at the beginning. When I turned it on, everything showed on the top screen up but when I tried to take the photo - the camera beeped as though it has focused, but the shutter button wouldn't take the photo, no matter how hard I pressed. I tried taking the battery out and reinserting and tried it with different lenses, with no success. I tried it a few days after coming home and it will now take photos, but I have to have my finger in the right spot on the shutter button and I have to press hard for it to take photos. I now have it set to multiple shots and whilst I have to press hard to take the first photo, but the subsequent multi photos are taken rapidly. I first thought that the shutter may have gone, but now I am not sure. It is a real mystery to me.

  2. #2
    Member
    Join Date
    04 Nov 2009
    Location
    Melbourne
    Posts
    347
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had that trouble with my 50D which was about 9 months old. Canon replaced the shutter button under warranty. However in about 6 months it started doing it again. Again replaced the button under warranty. When it first went it was a few days before we went on a holiday so I bought a 60D to do the trip and kept the 2 bodies. When the 50D was fixed the 2nd time I sold it as I couldn't trust it anymore. Search the Net, a common problem with the 40D and looks like it continued onto the 50D. If you have a grip, the 2nd shutter release on that will work and get you out of trouble if you didn't want to fix it straight away.

  3. #3
    Ausphotography Regular
    Threadstarter
    crafty1tutu's Avatar
    Join Date
    15 Jan 2010
    Location
    Seven Hills
    Posts
    1,826
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Russell. It does sound like this may be the problem. At the moment it is working, but not properly. I will probably take it in to Canon soon for a quote and depending on that I will decide whether I will fix it or not. They sell on Ebay now for around $400 so if it is too dear, it may not be worth it. I love macro and taking photos of bees in flight and a couple of times I have missed the shot because of the shutter. I was planning of upgrading and have the 50D as a spare, so I have bought a 7D as my main camera. We have just come back from four weeks in South Africa and I had wished that I had two cameras - on with the 100-400 and another with my 18-200 lens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •