User Tag List

Thanks useful information Thanks useful information:  0
Results 1 to 4 of 4

Thread: Nikon D90 Flash issue

  1. #1
    Member slo 057's Avatar
    Join Date
    25 Jan 2011
    Location
    brissy
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Nikon D90 Flash issue

    Hi, I have noticed that the flash on my D90 wont fire at all now, any ideas as to what would cause it?
    I tried google and got a whole lot of mixed answers to confuse me...

    any help will be great.

    Matt
    i couldnt think of anything smart to write so i wrote this instead...

  2. #2
    A royal pain in the bum! arthurking83's Avatar
    Join Date
    04 Jun 2006
    Location
    the worst house, in the best street
    Posts
    8,186
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Is there a possibility that you may have inadvertently set it to work as master in wireless mode and with no power output.

    In your camera's menu settings, there is a flash settings section that allows you to set the on board flash to work as the master controller for Nikon's wireless flash system.
    In that section there is also the ability to set the flash to control the other flashes, but not produce any power to add to the overall lighting of the subject.
    So all it does is to flash with enough (low) power to signal to the other speedlights to fire instead.

    But even with this setting, you will still see a flash of light from the flash itself .. it's just not powerful enough to light the subject very well.

    I can't ever remember seeing any other settings to completely disable the flash completely tho!

    Have you popped the flash up manually and it still doesn't work?
    Have you used any of the Auto scene modes that generally tend to use flash for exposure?


    If you still have no luck, it's probably the xenon tube that's blown(but this is purely a straight out and out guess!).
    Nikon D800E, D300, D70s
    {Nikon} -> 50/1.2 : 500/8(CPU'd) : 105/2.8VR Micro : 180/2.8ais : 105mm f/1.8ais : 24mm/2ais
    {Sigma}; ->10-20/4-5.6 : 50/1.4 : 12-24/4.5-5.6II : 150-600mm|S
    {Tamron}; -> 17-50/2.8 : 28-75/2.8 : 70-200/2.8 : 300/2.8 SP MF : 24-70/2.8VC


  3. #3
    Member
    Threadstarter
    slo 057's Avatar
    Join Date
    25 Jan 2011
    Location
    brissy
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i solved my issue, i just brought a SB 400 flash...

  4. #4
    Member
    Join Date
    04 Nov 2008
    Location
    Horsley / Wollongong
    Posts
    334
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    until that doesn't fire anymore..

    Jk's..
    Photographer & Retoucher at L'Obsession Secrète

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •