User Tag List

Thanks useful information Thanks useful information:  4
Results 1 to 9 of 9

Thread: Help - Error 99 - Canon EOS 50D

  1. #1
    Ausphotography Regular FallingHorse's Avatar
    Join Date
    07 Apr 2010
    Location
    Adelaide River
    Posts
    1,586
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Help - Error 99 - Canon EOS 50D

    Yesterday at the races I went to shoot and got an Error 99 which said to switch offand on again. I did that but got the same message. I swapped batteries (both were fully charged the night before) and still ... Error 99. I tried a different lens - no luck. I wiped down all the terminals/connections and still received the same error.

    After my initial panic - I tried the same lens on my other camera body with out any issues and shot with my back up for the remainder of the day. Between races, I tried the camera again but still continued to get the same message.

    When I got home I tried shooting without a lens on - just the cap and there was no problems ... it chattered away in high speed.

    Can anyone help with what might be wrong before I take it to the shop - I though that the lens connection might be dirty but the same happened with another lens and both lenses worked fine on my back up.

    I have read a number of other posts where people have got the same error only to have the camera go to the shop and nothing wrong can be found with it. I don't wan't to make the 200km round trip for the same.
    Jodie

    Gear - Canon EOS 7D, EOS 6D, 24-105 F4, 70-200 F2.8L IS, Canon EF 100mm 2.8 Macro, Sigma 10-20mm, nifty fifty, EF2xII, 580EX, 430EXII, EFx2 III and a long wishlist


  2. #2
    Account Closed
    Join Date
    05 Feb 2011
    Location
    CQ
    Posts
    922
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This is the problem with Canon's Error Messages....

    Err 99 is a general error that gives you no specific clue as to what causes it, When Canon look at it, they get a more detailed report from their diagnostics software. Unfortunately, if the error keeps happening, you have no choice but to take it to the shop. One last thing to try though, is to remove the back-up battery and replace it too. You'll lose all of your custom settings and stuff when you do that, but it's your choice.

  3. #3
    Ausphotography Regular
    Threadstarter
    FallingHorse's Avatar
    Join Date
    07 Apr 2010
    Location
    Adelaide River
    Posts
    1,586
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Bummer I will try removing the date/time battery and replacing it when I get home from work. Will let you know how I get on. The custom settings aren't that much of a problem compared to not being able to shoot at all

  4. #4
    Account Closed
    Join Date
    05 Feb 2011
    Location
    CQ
    Posts
    922
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well some models allow you to export your custom settings to a CF card, so check that first. No point in going through the process of setting them up again if you don't have to. This may not fix your problem anyway, but IS a hard reboot, so here's wishing you good luck!

  5. #5
    Ausphotography Regular
    Threadstarter
    FallingHorse's Avatar
    Join Date
    07 Apr 2010
    Location
    Adelaide River
    Posts
    1,586
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by camerasnoop View Post
    Well some models allow you to export your custom settings to a CF card, so check that first. No point in going through the process of setting them up again if you don't have to. This may not fix your problem anyway, but IS a hard reboot, so here's wishing you good luck!
    Wooot!!! It done the trick I took the little backup/clock battery out and wiped it down with a cloth & cleaned the terminals. Put it back in and Bob's you uncle! Thanks heaps for the info Saved me a trip to the camera repairman not to mention the $$$

    edit: and I forgot to mention - I didn't have to save/restore my settings, only the time/date
    Last edited by FallingHorse; 04-03-2012 at 10:34pm.

  6. #6
    Account Closed
    Join Date
    05 Feb 2011
    Location
    CQ
    Posts
    922
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well don't go counting those chickens yet. It may only be a temporary fix. If there is another underlying cause, it may raise it's ugly head again.

  7. #7
    Fishy bricat's Avatar
    Join Date
    06 Apr 2010
    Location
    Melbourne
    Posts
    772
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by camerasnoop View Post
    This is the problem with Canon's Error Messages....

    One last thing to try though, is to remove the back-up battery and replace it too. You'll lose all of your custom settings and stuff when you do that, but it's your choice.
    I will put that little gem in the back of the memory bank cheers Brian
    Cheers Brian.

    Canon 7D Kit lenses EFS 18-55 IS EFS 55-250 IS EF28-90 Canon EF 2xll Extender Sigma DG150-500 OS Speedlight 420EX. 580EX

  8. #8
    Ausphotography Regular
    Threadstarter
    FallingHorse's Avatar
    Join Date
    07 Apr 2010
    Location
    Adelaide River
    Posts
    1,586
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by camerasnoop View Post
    Well don't go counting those chickens yet. It may only be a temporary fix. If there is another underlying cause, it may raise it's ugly head again.
    Bummer..... I prefer the chickens Well fingers crossed that it is a while between Error 99's

  9. #9
    Ausphotography Regular
    Threadstarter
    FallingHorse's Avatar
    Join Date
    07 Apr 2010
    Location
    Adelaide River
    Posts
    1,586
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by bricat View Post
    I will put that little gem in the back of the memory bank cheers Brian
    I wrote it down in my camera's manual which is usually in my bag

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •