View Full Version : Canon 50D wireless remote issue

21-09-2010, 8:25pm

I recently purchased a Hahnel Giga T Pro wireless remote control for my Canon 50D as I want to do some astro shooting. This is my first time using a remote shutter.

The problem is that the camera does not respond to the remote control. The receiver is responding to the transmitter (the LEDs on the receiver change colour when I half press, and fully press the transmitter shutter button) however the camera does not seem to recognise the receiver that's plugged in to it. I have the receiver connected to the camera via the N3 connector, which doesn't seem that tight incidentally, but maybe this is normal I don't know?

There seems to be very little help on the manufacturer's website or on google, and I haven't found much help in the camera manual about using remote controls. Has anyone used this remote control before, and is there anything special I must do in the camera settings to enable the camera to recognise the remote control?

The wireless transmitter and receiver seem to be working ok, it's just that the camera does not know it!

21-09-2010, 8:48pm
Just to update, now when I connect the transmitter directly to the camera via the cable, the camera will now fire. It wasn't doing this before, it just started working!

However, the wireless functionality still doesn't work (even though the LEDs respond like it is working), and I have re-checked the Tx/Rx are on the same channel, turned them on and off again etc.


21-09-2010, 10:05pm
I have one of these for my 7D and 5D and have no trouble at all, from the minimal use it has had at present

04-10-2010, 6:01pm
Faulty unit, it was replaced by the vendor and it now works fine.

18-03-2012, 9:53am
I have just bought the same Giga T remote and had the same problem. Took it back to the shop and found that I wasn't clicking the cable into the reciever hard enough. It felt like a very loose connection at first but you will feel a very definite click when pushed in correctly. It feels like you are forcing it in. I have only had it for a week and a half and now the led screen on thr transmitter has disappeared . I have put in a new battery but still no luck. Not sure if there is a reset function I have to punch in after changing the battery. So back to the shop we go.

Changing the battery in the transmitter is not as easy as it looks in the manual. There is a little gold clip that I'm not sure exatly how you are suppose to unlock. Will post how to do it when I find out how it's done unless someone has already worked it out. I just pulled it back and pulled the battery out.