View Full Version : I'm really stuck - anybody be able to help me please?

04-06-2010, 3:22pm
I'm at my wits end today, just spent four hours trying to figure my problem out, googled, read the manual, I can't figure it out.

I've got my Nikon D300 and Speedlight SB 800. All I'm trying to do is get the flash to flash on the camera. I did it the other night, but this morning, it got really erratic with the flashing. Sometimes it would, sometimes it wouldn't. I changed the batteries. Still the same. So I started fiddling with the Speedlight controls and now I've got myself into a total mess.

I've read the manual, and I'm still lost.

I haven't changed any settings on the camera since I used it last. I did get it to flash attached to the camera, but the photos were nearly black. So I'm thinking sync speed maybe? I tried the on camera flash, and the exposure is fine.

I have it on TTL at the moment, should I have it on remote or master? I thought I had it on remote this morning when it was working, but now I can't remember.

I think I've had it on every setting possible. And I'm stumped.

Just wondered why my pictures are dark? And what settings should I have the Speedlight on?


04-06-2010, 3:24pm
Don't panic

Put camera on p
Put flash on ttl
Put meter mode on camera on matrix

Try that

04-06-2010, 3:27pm
Oh, before you do that do a reset of the flash, just check the manual but you basically hold down a couple of the buttons for a few seconds

I @ M
04-06-2010, 3:33pm
Ok, let's start with some details instead of PANIC :p

Detail what your camera is set on, mode, aperture, shutter speed and very importantly whether the focus is et on the camera to AF-S or AF-C (the little switch under the lens on the l/h side) but most importantly did you set the camera to a different menu bank that has the SB800 set as a commander unit?

Then detail the settings on the flash. Take a picture of the lcd and post it. This is all starting to sound as though either the camera is set for the 800 to be a commander or that the 800 is set to be a remote.

04-06-2010, 4:02pm
Hi Kiwi

Yes I did what you said, and it worked. But then when I tried it a couple of seconds later, it wouldn't work.

Flash Settings: TTL (then a squiggly line like a snake with an arrow at the top). ISO 100. AF-ILL 0.6-4.2m. M Zoom. 28mm f7.1. It was on Master. But it's now on SU-4. WP is on. AF is on.

Camera is on Manual. Shutter speed is 180 f8. +1.5 Dev. And on matrix now.

So now it won't flash again at all.

Its on single focus.

04-06-2010, 4:03pm
I'll just check that Commander mode, but I haven't changed anything since last time. Be back.

04-06-2010, 4:03pm
Basic I know, but is it mounted properly in the camera hotshoe? Sometimes it can be a tight fit and if you have it in the 'lock' position it won't slide all the way in.

If it's mounted properly then PANIC :D

If the flash is in TTL mode then it is NOT set to remote so should work properly in the camera hotshoe.


04-06-2010, 4:08pm
SU-4 mode might be the problem. Hold the SEL button down for a few seconds and then press it again and select the 'OFF' mode. see how you go.


I @ M
04-06-2010, 4:11pm
SU 4 is the remote optical setting, that is totally wrong to start with. Get your manual out and do the 2 button reset to get it back to default ttl settings.

04-06-2010, 4:19pm
OK, so I changed it to TTL off. And it flashed on the camera. The picture is black though.

I think there might be something wrong with it actually, the menu on the Speedlite keeps freezing, and I can't even turn it off, I have to take the batteries out. And now it's not flashing again. I'll take it to the camera shop tomorrow morning, and see what they think.

04-06-2010, 4:20pm
Oh, yes, it's mounted properly. Thanks.

04-06-2010, 4:27pm
Nup! you want TTL to be on.

TTL is good, TTL is (almost) brilliant(for those of us that can't be bothered to understand flash :p)

When you select TTL and you then select matrix metering for metering on the camera you get TTL/BL which is even better than TTL.. and so forth and so on.

All you need to do is to turn off the remoteness of the remotability of the flash when mounting it to the camera's hot shoe.

Once the SB800 is set to not act in a remote manner in any way, it will work properly.

if not.... then hit the PANIC button again :p

04-06-2010, 4:35pm
OK thanks, guys, it's flashing and it's on TTL, but I will have another read of the manual. Thanks for all your help.

05-06-2010, 6:24am
You lot are such a knowledgible bunch!!!! I am glad I joined this site cheers Brian