View Full Version : snow leopard 10.6 and DDP

21-01-2010, 7:47pm
Hey guys I am having problems installing DDP on my new iMac. I have the original disk for my 40D (EOS digital solution disk?..is that it?) and when try to install it a msg saying that I need to download Rosetta is coming up. The when I try to download this Rosetta think it is not working.

Any help? I really need this as I will not have photoshop for the next couple of weeks and need to work on some prints

Cheers in advance

22-01-2010, 1:46am
Got mine running without Rosetta. It just worked.
What version of EOS Digital Solution Disc you got? and with what version of DPP.
My Disc is 11.1 with DPP Ver 2.0

22-01-2010, 9:22am
mine is version 15.1. is it the solutions disk that I am meant to load?

22-01-2010, 9:33pm
Yes it is.
Printed on the disc it should give a version number for the DPP. What is it?
When you insert the disc it will appear on your desktop. Double click it. This will open another Window. Click on Oceania. Click on Install. Select Custom Installation, accept the license agreement then choose the items you want installed. Accept the install location and click on install. The rest should be up to the installation package.
Any dramas then PM me and I will try to help.

22-01-2010, 9:45pm
Rosetta is on the Snow Leopard disks if you need to install it.

23-01-2010, 2:04pm
i tried to install DPP first by dragging to the desktop
then it said I didn't have Rosetta so then I installed Rosetta off the snow leopard disks
So everything installed fine (photo stitch, image browser.... etc) except for DPP. It said that DPP is already installed. However I can not find it anywhere on my hard drive (as i want to find it then delete it and re-install it)

My disc is Version 15.1, DPP 3.1

24-01-2010, 12:38am
Mine's hiding on the Hard drive, Applications, Canon Utilities, DPP.

24-01-2010, 10:22am
yeah see, everything is in canon utilities except for DPP... :confused013 starting to get quite frustrated. Its is times like this that I wished I was a little more computer savvy

24-01-2010, 10:24am
When I put the disk in the program loads fine and I can use it....but that not all that convenient