View Full Version : Nikon; ViewNX(v1.5.0) .. PoS!

23-10-2009, 11:40pm
Pile of Shishkebabs! :D

Got a message asking if I wanted to update(from 1.4.0 -> 1.5.0) and so of course, I did! :action:

.... nearly two hours later, and both the versions I downloaded wont start up(properly) on my PC.

v1.4.0 starts and loads perfectly well tho(had to revert back to it)

The issue I'm having is that, VNX 1.5 starts, then immediately closes down :confused013

.. stoopid Nikon!.. why can't they leave the software development to companies that know how to do it!

24-10-2009, 12:33am
No way I'm going to upgrade mine now!!!

I @ M
24-10-2009, 5:43am
No problems on 3 machines here Arthur.

The only suggestion I can think of is to check whether you downloaded it from Nikon Asia, apparently different regional settings can screw up the installation ----- :(

24-10-2009, 9:38am

The only suggestion I can think of is to check whether you downloaded it from Nikon Asia, apparently different regional settings can screw up the installation ----- :(

Stupidly ..... :confused: the 'more info' link took me to the Nikon Eurpoe website, so I just downloaded it from there.
Then I went to the next link in my bookmarks, which is Nikon USA and the same issue upon installation again!(from the NikonUSA download).

@ seastorm! It could just be a problem with my machine.. so don;t be afraid of installing it.
There doesn't seem to be a compelling reason to update. A few added GPS/geolocating features!!.. why no crop tool!! :action:
But I'd be curios as to whether it works on your machine too.
Lucky for me I keep the old file(the 1.40 installation exe) so it was easy to re install 1.4 again, but I did uninstall, clean out the registry, restart .... da de da, ra, ra, etc, etc..... ! :(

I'll try again from the Nikon Asia site too.. just in case

25-10-2009, 1:25am
Interestingly enough, my ViewNX can't find any updates, and it's on version 1.4.0!!! :crzy:

I @ M
25-10-2009, 6:58am
Interestingly enough, my ViewNX can't find any updates, and it's on version 1.4.0!!! :crzy:

Putting it politely --- Nikon can sometimes (ok all the time) be a little "backward" in coming forward with updates. :D

New versions of software can be found here. (http://nikonasia-en.custhelp.com/cgi-bin/nikonasia_en.cfg/php/enduser/std_alp.php?p_sid=4Is3uBoj&p_lva=&p_li=&p_accessibility=0&p_redirect=&p_page=1&p_cv=1.224&p_pv=&p_prods=0&p_cats=224&p_hidden_prods=&prod_lvl1=0&cat_lvl1=224&p_search_text=&p_new_search)

25-10-2009, 8:57am
Is Nikon Message Center installed and running?

the program itself doesn't look for updates, NMC does.
The way it seems to work, is that NMC is fully independent of any other Nikon software installed, and isn't called into action if there's a specific update for the program you may be currently using.
That is, if you're running CaptureNX as well, and check for updates, via the Help/About menu, it calls NMC and NMC just checks all available updates for your installed Nikon software.

.ie I just checked for updates via CaptureNX2 and it only had ViewNX 1.5.0 in the update list.

Check your add/remove programs list to see if NMC is installed correctly, otherwise just go to the download site and do it all manually anyhow.

25-10-2009, 9:48am
Yup, the Message Centre is running. Tried just about everything, but no joy. I'll probably leave it alone for now, no reason for me to update...yet... :)

25-10-2009, 1:01pm

I just downloaded and installed it with no problems. It was from Nikon Asia site (the file is called S-VIEWNX-150WF-INTEN.exe). I save the file then istall it, rather than just isstalling directly. I read that version 1.4 had some prblems with re-sizing photos, so I never installed that one, I went from 1.3 to 1.5.

25-10-2009, 5:46pm
If anyone can read a DrWatson log(and can make sense of it!! :rolleyes:) .. I can send it for further investigation??

I'm going to send it off to Nikon somehow, to get them to figure something out.

The problem I'm having is that v1.5 opens, commits to displaying the thumbnails(I use the hybrid thumbnail/image viewer screen), loads the thumbnails, and shuts down as it's about to load the first image in the main image screen.
if I subsequently try to open it again, the shut down process is more immediate.

I tried all three files form USA, Europe and Asia, and they all do the same thing on my PC.

Over the next week or so, I'm going to try to find the time to install a new HDD, load a fresh copy of Windows(whatever??.. maybe XP for now) and at least see if it's a hardware, or software issue.

Read about one other chap that has the same issue(immediate shutdown), but he's on a Mac.

Curious too, without any image editing processes running, how much memory is it using on your systems?
ATM my v1.4 is using about 75M of RAM, just sitting idly.

Edit any NEF, and it then screams up to 700M as it's processing the edit steps, and then once it's done editing, it will roll back down to about 350M just sitting at idle again.
(I was thinking maybe a memory issue for me??.. dunno? as I can't get it to stay open long enough to fully load).


I @ M
25-10-2009, 6:00pm
Just had a look at it to see what it was doing on the machine here Arthur, similar sort of figures during edit stages and idle but still no problems with it. :confused013

25-10-2009, 11:59pm
OK.. the plot thickens!!

I took this opportunity to install the eval copy of Win7 onto a new HDD, having just gone through many hoops to do that, and finally installed, apart from FF, the first thing I wanted to install was VNX1.5
Installed perfectly, and NMC updated to the newest version, and everything is kind'a hunky dory.
Opened VNX 1.5 and viol#à! opens and stays open. :D

...... NOT! .. well kind'a not.. bu tit amounts to the same thing!

.. what am I on about?

When I first load VNX1.5, it automagically wants to view the images in your My Images folder.
Once you have it installed, it then points to the last folder open.
I have no images in my pictures folder, and VNX1.5 works fine.. no crashing.
Soon as I point it to any folder with an image.. NEF/JPG/TIFF.. it crashes.

STOOPID image viewing program!!.... doesn't want to view images!!! :laughing1:

I'm going to go back to v1.4 again.. but by golly miss molly, it freaking flies on a fresh system! :th3:
(when I finally get it working I 'spose!) ... does actually make sense, as it took all of 5 sec to load the 100(or so) images in the last folder I tried to point it too. after all the thumbnails loaded, I got an windows error message saying that VNX has stopped working and that Windows is trying to find a solution. Nikon need to find(Me) a solution I suppose.
On first start up, there's a wee delay in crashing..
I know it's not a codec issue, as I currentlyhave no codecs installed, and I had the latest installed on WinXP(now I'm testing Win7).. and jpgs don't require any specialised/specific codecs to view with any software.
I'm back to square one, and from what I've seen anyhow, there's no compelling reason to update(apart form the geo-positioning enhancements for those that can use it).

So.. ATM it's still a non event, but now at least I know what the issue is.
Just have to figure out why!? :confused013

26-10-2009, 12:51am
Just downloaded ViewNX 1.5 today and running Windows 7 and it works like a charm :D Just using it as a browser as the picture gallery browser in Vista/Windows 7 doesn't like NEF's and keeps crashing every 5 minutes!


26-10-2009, 9:02am
it's definitely a hardware issue for me??? :confused013

So far i had a quick peek at my NEF's using the media center image browser thingy, took a while to index all the images, just on my main drive tho.. and as far as I could see, I had no crashes after (minumum)5 mins.... maybe 10, or more?(I really should get off to work :o)

haven't installed the latest v1.8 NEF codec yet either, so they're native to Win7.

VNX 1.4 is now working perfectly too.. and it's feels so much faster now without the 7 odd years of clutter and garbage of my old system.

26-10-2009, 9:14am
I've got version 1.00 of the NEF Codec at the moment.

Windows 7 has definitely made things run a bit quicker for me. In Capture NX the NEFS were taking about 17 seconds to fully render and now down to about 10 :D The system still seems to using about the same amount of memory as Vista when idling though.


29-10-2009, 10:16am
I'm having no issues whatsoever with 1.5 on Win7.. in fact with 1.40 I couldn't get the geotagging working and now I can. I'm still haveing problems with pasting geotag information though... I can copy fine but when I open the next image and right-click, however all of the options are grayed out. If anyone could tell me what their process is for "batch geotagging" in ViewNX I'd appreciate it.

29-10-2009, 2:10pm
Oooo! .. haven't done batch geo tagging yet, but I suspect that if you highlight, or tick the appropriate images then the location data is sent to those images?? :confused:

My issues with v1.5 are definitely hardware related, as I'm having the same issue on WinXP as well as Win7.
What/why the program can't display images any more is beyond my level of understanding.

I'll try to test the batch geotagging on a few images later, if I have the time too.

29-10-2009, 2:59pm
You might have a corrupted image and every time it hits that image it crashes. Might be worth checking if there's a correlation between when it crashes and which image/image set is being used or viewed.


Big Pix
29-10-2009, 3:02pm
....... all fine on my iMac and PowerMac.....

29-10-2009, 7:08pm
nah, no corrpted images, as this issue is in any folder that has images.

The only savings grace I have is that on first attempt on opening VNX1.5 I have just enough time to click on another folder that has no images.. say the root of a photo folder, where only other folders are displayed. If I try any folder.. ie. all folders that I've tried so far... with any image, whether jog tiff or NEF, the program hangs, then just shuts down.

I did load up DrWatson on the XP install, and saved a copy of the cryptic error message(cryptic to me, and programming dunce!) so somewhere in there is the clue as to what's happening.

Not an issue, as yet.. just curious as to what they've changed that caused this.
Obviously some image loading optimisations, for the purpose of speedier thumbnail, or iamge loading or whatever, that is at odds with my PC.

i'm going to load it only my kids laptop too, where I dare say it'll work ok.. but between kids, work, new PC install... etc.. and having a couple of hundred images to review/edit/upload, it's kind'a taken a back seat for the next few days!
Still haven't tried to sort out my new email program issues! :p
(priority is always with the review/edit/uplading of new images of course ;))

I @ M
29-10-2009, 7:37pm
OK, time for a phone call I reckon Arthur, 1300 366 899 and ask for Ray.
If he knows about the problem he will have sound advice to cure it. If he doesn't know of it he will direct you to the Asia help desk to get it looked into.

29-10-2009, 7:45pm
Now!... I knew there was someone I knew that knew someone that might know! :D

I'll try to email him the DrWatson error log too.

18-11-2009, 11:48pm
I also have been using the latest version for quite some time without any problems. Mind you, I don't do anything except basic quick adjust and exporting RAW to JPEG with it.